Orson's Dead Beef

Go ahead and grab some deadbeef

ForumConverter July 26, 2011

ForumConverter migrates post, topics, and users from one forum to a WordPress compatible forum. Currently, ForumConverter supports phpBB 3.0.9 to bbPress 2.0 Beta 4 conversion in addition to migrating users as subscribers to your WordPress blog.

ForumConverter migrates users from the source forum database to WordPress compatible forum so that migraters can take advantage of BuddyPress social networking. This is not a bridge.

For phpBB-to-bbPress conversions, ForumConverter is capable of…

* reproducing the same forum tree structure for bbPress
* reproducing forum post using the same same user, timestamps, sticky flag
* allowing converted users to sign on using their existing phpBB password.
* converting between BBCode or native bbPress HTML markup
* supporting inline attachment conversion and whole topic/reply attachment conversion.
* migrating of instant messenger info, global moderator membership, and emails.
* password protected forums support using the same phpBB password

Some things that are impossible to do for ForumConverter for phpBB-to-bbPress conversions

* Complete conversion of custom BBCode. Only YouTube BBCode is supported but BBCode lite does not support YouTube tags.

Changelog
1.12
Security Fix: Sanitize signatures.
Bug Fix: Redirect the user back to the signature page after save.

1.11
Correct versioning for all plugins.
Cosmetic fixes for support for bbPress 2.0.
Few fixes to bbcode conversion markup contributed by Vato.
Fixes to signature plugin to edit the signature onto the current user profile.

1.10
Bugfix: Fix incorrect url generated for attachments that are not inline.

1.09
Bugfix: Fix displaying of signatures under ie8

1.08
Created the “Orphaned Topics” forum to store orphaned topics
References to missing users now link to Anonymous by default
Bugfix: Fixed (mismatch) problem
Added FormConverter forum passwords editor/remover in the “Forum Attributes” panel
Signature rendering added with BuddyPress and WordPress signature editors
Bugfix: Fixed infinite loop for database retry
Cosmetic changes for support for bbPress 2.0 Release Candidate 4

1.07
Update avatar support for BuddyPress 1.5 beta 2
Prevent empty folder creation for posts without attachments

1.06
Add buddypress avatar support
Reconnect on disconnect

1.05
Bugfix: increase execution time to 1 hour for those who don’t have it in their php.ini
Bugfix: fix attachments for those not attached inline

1.04
Remove end of file whitespace to get rid of plugin activation warnings.
Cosmetic changes for bbPress 2.0 rc 2

1.03
Sticky now really become stickies
Support for global announcement to super sticky conversion
Support for topic locking
Support for forum post locking
Support automated forum conversion resulting in forums being automatically marked hidden, read only, or read or writable
Bugfix: keep messages contained in log viewer
Prevent banned users from subscribing, or replying or creating topics
Better user merging to prevent orphaned ownership and better preservation of user capabilities. Existing users on
WordPress installation no longer get deleted.
Prevent bots from being listed as subscribed user
Seperate post conversion auth module
Bugfix: fix role to show it properly on combobox.

1.02

Duplicate attachment resolution
Suppress file removal warnings

1.01

phpBB password protected forums support
Recoursive cleanup of attachments for failed conversion

1.0
Initial release.

This plugin is free under the terms of GPL version 2 but a donation is appreciated. You may grab a copy of it here.

Advertisements
 

174 Responses to “ForumConverter”

  1. Corinne Says:

    Hi, I’m hoping to use your plugin to migrate all my phpBB topics to a bbPress board. I have over 10,000 users and over 50,000 posts. Will this impact the process much and is there a possibility that I will run into errors? Also, I have an account on both WordPress and phpBB with the same username. On the plugin repository FAQ you say there may be some destructive conversion of users with the same name. Will this have an effect on me (as I need to retain my administrative permissions on both the forums and WordPress). Thank you for creating this!

    • ihotline Says:

      As I mentioned in the FAQ you should convert your website in a sandboxed environment or test server before you upload your changes on a live server. If your name is admin on both phpBB and WordPress installation, the converter will not clobber that user. In all other cases the converter will clobber the WordPress with user data gathered from phpBB breaking authorship association. Global moderators and admins of your phpBB forum will take on bbPress’ Forum Moderator role. You can modify the source code to control how users should be merged into your WordPress or add exception so that your authors will not be clobbered and lose authorship over articles.

  2. Ben Jackson Says:

    i’m getting the ”
    Warning: Cannot modify header information – headers already sent by (output started at /home/benjacks/public_html/alphashows.com.au/wp-content/plugins/forumconverter/fc-options.php:205) in /home/benjacks/public_html/alphashows.com.au/wp-includes/pluggable.php on line 934″

    error.

    Why? I’m using the beta 3 version as well instead of the RC. 3.0.9 as well. I just don’t get it.

    Any help would be greatly appreciated.

  3. Ben Jackson Says:

    i’ve tried using 1.0 and 1.02, (even though both display in wp as 1.0) – no change

  4. Ben Jackson Says:

    i get a warning when i activate that it generates 5 errors

    • ihotline Says:

      When you first activate the plugin it does cause warnings about modified header info. It shouldn’t cause any problems conversion process.

      I’m still trying to figure out the cause of those errors.

  5. Ben Jackson Says:

    Can I use the Release candidate or does it still have to be beta 3?

  6. Ben Jackson Says:

    awesome i’ll give it a try.. aaaahhhh brown background, freaked me out hahah 🙂

  7. Ben Jackson Says:

    um,,, where can i get 1.0.4, the one on wordpress is 1.03 and it still gave the activation warnings.

  8. Ben Jackson Says:

    going back to default theme and no plugins didn’t help by the way, but i don’t think I’ve tried your latest version. could you please email to me ben AT benjackson.com

    thank you!

  9. Ben Jackson Says:

    DUDE you are a LEGEND!!!! I think it’s worked now!!!! You should not take a break on this, unless it’s completely working now – you deserve a break, but I have searched for 2 days trying to get a solution for getting phpbb over to the plugin version of bbpress. you’re the only person in the world with this solution and you should make a big deal of it!!! Send me an email ben AT benjackson.com with your paypal and I’ll send you some money as a donation.

  10. Ben Jackson Says:

    i spoke a little too soon, it did import everything, except the posts. not sure if i was supposed to leave it on that page that come up after i clicked the button – it looked like it wasn’t doing anything though, but it did say ‘please wait converting posts’. how do you know when it’s finished?

    • You leave it running then the box above should light green or red. If it is yellow, it is still processing. Another indicator it is processing is if the tab’s browser icon is animating or it shows the usual browser busy animation.

      • Ben Jackson Says:

        no i know that, that’s my point, the browser stops going, no longer animating. it stops as soon as it brings up the yellow box. i’ve left it this whole time and nothing has changed.

  11. Ben Jackson Says:

    It seems to get to this and then just stop…

    relinking forum hierarchy
    fixing subcounts
    done processing forums
    converting posts…
    converting posts

    • If it throws a red then try to activate the debugging output in PhpbbToBbpress.php by uncommenting show_errors() and also uncommenting fc_echo() or adding comments to locate the area of the error. It maybe that there was a condition that the plugin did not catch which we need to modify the plugin to take corrective action. Errors like orphaned topic that doesn’t have a forum can cause the plugin to halt. Maybe put a $this->fc_echo() before every mysql query code segment and inspect the debug errors at the bottom of the settings page.

      • There is one case left out in the conversion where there was an announcement/post orphan that supposed to be chained to a previous reply. We may need to fix that scenario if your conversion went wrong and matches this test case.

      • Ben Jackson Says:

        it never gets to red, it just stops. i’ll uncomment the show_errors and fc_echo and see what comes up

  12. Ben Jackson Says:

    that’s helping. I uncommented everything and can see more output. But I can’t get it to work yet. the errors seem to do with attachments not being present. lots and lots of errors like the one below. I had a problem with the forum where all the attachments were lost I think. I’ve also been fiddling with the setting in forum converter for the path to the upload folder but none of that changed anything. Any ideas?

    WordPress database error: [Table ‘benjacks_db.phpbb3_fc_attachments’ doesn’t exist]
    SELECT * FROM phpbb3_fc_attachments WHERE post_msg_id=1

    • You can disable the attachment process by setting $this->processAttachments = true; to false. Also your development server may have a different upload path from your production server. You need to check the upload path for your wordpress installation in the wordpress admin backend > settings > media section. You may also check the upload path you provided in the setting section of ForumConverter. You can also try to fix the problem at the code level and if you do you should try to isolate the problem using many fc_echo()s in the conditional containing processAttachments.

  13. Ben Jackson Says:

    oh oh oh,,, i also saw this at the bottom. how can i fix that? Maybe that’s the problem:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/benjacks/public_html/alphashows.com.au/wp-includes/wp-db.php on line 1353

    • You need to maybe modify the php.ini to allow for longer execution time. php has a built in timeout for scripts. Mines is set to max_execution_time=1440

      • If that is the problem, then I would need to add a patch to extend the time longer for others who use this. When your done put it back to the previous value.

      • Ben Jackson Says:

        i don’t have access to root access and when i put it in the .htaccess file it gives an internal server error. this has been a problem before. so if you can put in something to patch it that would be good. I think most people by default are at 30 secs, so it’ll come up often as i’m sure most forums would take longer than 30 seconds to convert. let me know if you have any other suggestions, i’m going to keep trying to get some hack to change it to 1440 or something.

  14. try adding set_time_limit(1440); to the constructor or under $this->processAttachments = true;

  15. Ben Jackson Says:

    Ok I’ve added in set_time_limit(1440); and it no longer quits after 30 seconds. LEGENDARY.

    So keep that in there 🙂

    I put it in after processattachements (which I still have turned off for now).

    So it made it to the end of the posts as far as I can see, but still no posts are present in the forum when I look.

    The errors underneath are now:

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_first_post_id=1

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_id=1

    error in topic search (1): MySQL server has gone away
    WordPress database error: []
    SELECT * FROM wp_fc_map_posts

    These are the last things it was doing in the yellow box (still yellow):

    relink top level posts to forum and subforums
    linking post #1
    marking as reply

    • I am looking for a solution for this right now.

      • Ben Jackson Says:

        thanks mate. i wish i could do something to help, but i’m hoping this helps others too just finding all these errors. i’ll wait until you have a solution. thank you so much.

      • Try adding ini_set(‘mysql.connect_timeout’, 600); ini_set(‘default_socket_timeout’, 600); which should keep the socket connection and the mysql up for 10 minutes. If it dies again, try to increase the timeout values for both to 1200 for twenty minutes or 60*minute value.

  16. Ben Jackson Says:

    i added those lines after the other ones i added, but to no effect.

    i tried this too [http://thesocialmediaguide.com/wordpress-blog/solution-for-wordpress-database-error-mysql-server-has-gone-away-for-query]

    but that eventually resulted in another internal server error.

    so i’m stuck again…

    • did you apply that to the $fdb object? Or what i ment to say was did you put $fdb->query(“set session wait_timeout=1440”); just before $fdb->show_errors(); in convertPosts()? The default value is 8 hours but your host may have changed it.

      • It should be lower value than the one I put in the example since it is between each query or mysql request that article suggest. “The number of seconds the server waits for activity on a noninteractive connection before closing it.” according to MySQL documentation.

  17. Ben Jackson Says:

    this is what i have. what do you suggest for the values? I’m not even sure this is what you wanted…

    public function convertPosts()
    {
    global $wpdb;

    $fdb = new wpdb($this->forumLoginSrc->username, $this->forumLoginSrc->password, $this->forumLoginSrc->databasename, $this->forumLoginSrc->hostname);
    $fdb->query(“set session wait_timeout=1440”);
    ini_set(‘mysql.connect_timeout’, 600);
    ini_set(‘default_socket_timeout’, 600);
    $fdb->show_errors();
    $wpdb->show_errors()

  18. Ben Jackson Says:

    this time i got an internal server error 500 again. i’ll try lower values

  19. Ben Jackson Says:

    having the set session in that section is what cause the internal server error. it works again without it (i’ve still got it earlier around the process attachments bit

    but still dies on that same error of mysql server going ‘away’.

  20. Ben Jackson Says:

    so no matter what i do i get this (see below). So yeah, still in a very broken state. I’m in LA so if you’re in San Diego it’s definitely bed time. I just wanted to try and get this sorted tonight as it’s been frustrating me now for a few days.

    Thanks

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_first_post_id=1

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_id=1

    error in topic search (1): MySQL server has gone away
    WordPress database error: []
    SELECT * FROM wp_fc_map_posts

    • I am trying to replicate the conditions to trigger this bug. So far nothing. It is either a MySQL configuration or PHP dropping connection early or something causing the “MySQL server has gone away” error. Try out the 1.05 update that fixes attachments also.

      • Ben Jackson Says:

        Yeah, i have been researching all night and just now for the last couple of hours to find the problem. Found lots of people talking about this server gone away thing, most of them suggest editing some file in the includes folder, but i’ve done what they say and it makes no difference. i’ve tried putting in sleep commands in the plugin, all sorts of things to try to solve it. either it makes no difference or i get internal error 500’s. I will try 1.05 and see how i go.

  21. Ben Jackson Says:

    This version of the plugin with a stock wp-db file gives an internal server error 500 after a couple of minutes of loading

  22. You might also want to check the tables for data corruption. I had to repair/restore my db tables once when I was developing this plugin after a browser Flash crash.

  23. Ben Jackson Says:

    .htaccess files have nothing in them. i deactivated theme, all other plugins except bbpress. and the 1.04 plugin works fine (except for the final error of mysql going away)

  24. Ben Jackson Says:

    so any ideas on what to do next? I’ve run out of ideas.

  25. Ben Jackson Says:

    do you want me to send you the phpbb forum details so you can try on your system

  26. Have you tried setting up and install phpbb, mysql, apache, wordpress, and configuring your hostfile whatnot to preforming the conversion your computer with the same passwords and hostname? When your done upload the mysql db back to production server. You want to do this to take full control of the wait_timeout or bypass restrictions that your webhost uses. From http://www.yireo.com/tutorials/magento/magento-administration/1284-mysql-server-has-gone-away another reason why one might see “MySQL server has gone away” is that the server could be under high load and to drop requests.

    • Ben Jackson Says:

      this is quite difficult for me to do. and it also doesn’t solve YOUR problem of wanting to iron out any issues average people might have with your plugin. I can get in there and code and edit things

  27. Can you send me like the last 20 lines from the yellow output window and the output at the bottom of the page? Did it stop at “relink top level posts to forum and subforums”?

  28. Ben Jackson Says:

    sure can. it’s pretty much as i posted before. This is using 1.04 as 1.05 just gives the internal server error.

    converting Re: Sleeping Beauty 2011
    relink top level posts to forum and subforums
    linking post #1
    marking as reply

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_first_post_id=1

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM phpbb3_topics WHERE topic_id=1

    error in topic search (1): MySQL server has gone away
    WordPress database error: []
    SELECT * FROM wp_fc_map_posts

  29. Ben Jackson Says:

    i have activated the plugin you suggested and changed the plugin to wpdb2

    It has gotten rid of the server gone away error, but it stops at the SAME POINT in the yellow box, and the error output is now the following, which makes more sense but I’m not sure how to fix.

    WordPress database error: [Table ‘benjacks_alphashows.phpbb3_topics’ doesn’t exist]
    SELECT * FROM phpbb3_topics WHERE topic_first_post_id=1

    WordPress database error: [Table ‘benjacks_alphashows.phpbb3_topics’ doesn’t exist]
    SELECT * FROM phpbb3_topics WHERE topic_id=1

    error in topic search (1): Table ‘benjacks_alphashows.phpbb3_topics’ doesn’t exist
    WordPress database error: []
    SELECT * FROM wp_fc_map_posts

    • Use phpmyadmin or use mysql command line to confirm
      (1) that the table phpbb3_topics contains a row with a column value topic_first_post_id of 1
      (2) that the table phpbb3_topics contains a row containing a column value topic_id of 1
      (3) that the table phpbb3_topics exists

      If option 2 search fails let me know. The code is telling me that the selected post is not a topic, then it must be a reply and yeah oh we didn’t find a topic to attach it to so let’s stop. We have to confirm that the topic_id 1 exists if not then it must maybe need to be attached to a reply which is the special case I mentioned previously. The solution is either to throw the orphan post away or chain it properly so that reply connects to reply. Right now ForumConverter can chain topic to reply but not reply to reply which happens to be the case if you may have messed with global announcements.

      • Ben Jackson Says:

        yes all 3 are confirmed, i can send you a screenshot if you want. All with 1 as the value. It is a topic.

        haven’t messed with global announcements

      • I am assuming the user has read permissions to access the table and the phpbb3 tables are not corrupt. I am kinda stuck right now. It like saying that it cannot see the table. It can be a spelling error but I doubt that since it worked pass the convertUsers part. You might wanna do a var_dump on $srctopic and $dsttopic to see if it properly assembling the sql statement or an essential debug message is not being skipped.

      • Also there should be no MySQL errors. I just did a run and I see no error except missing attachment file copy() errors.

  30. Ben Jackson Says:

    Ok yes, the user is an admin with full access.

    i repaired all tables just in case, no change. in both wordpress db and the phpbb database.

    explain where to put var_dump on those things. I’m not a coder in php or mysql etc.

    I don’t know if there are mysql errors but i assume this is one, but i have no idea how to fix it.

    • 
      Try replacing
      
      						if ($srctopic === NULL)
      							$this->fc_die('error in topic search (1): '.$fdb->last_error);
      
      with
      
      
      						if ($srctopic === NULL)
      							$this->fc_echo('error in topic search (1): '.$fdb->last_error);
      						else
      						{
      
      For part II find,
      
      						if ($status === false)
      							$this->fc_die('error inserting _bbp_topic_id'.$wpdb->last_error);
      						}
      					}
      
      					//lookup user and set post author
      
      
      
      and replace with
      
      
      
      
      							if ($status === false)
      								$this->fc_die('error inserting _bbp_topic_id'.$wpdb->last_error);
      						}
      					}
      
      					//lookup user and set post author
      
      .  This should skip a reply with a missing topic.
  31. Ben Jackson Says:

    I assume you meant in the part II to replace die with echo, as I cannot see any difference in what you posted.

    I have made those 2 changes, making it echo instead of die.

    Now i get these areas:

    WordPress database error: [Table ‘benjacks_alphashows.phpbb3_topics’ doesn’t exist]
    SELECT * FROM phpbb3_topics WHERE topic_first_post_id=1

    WordPress database error: [Table ‘benjacks_alphashows.phpbb3_topics’ doesn’t exist]
    SELECT * FROM phpbb3_topics WHERE topic_id=1

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1]
    SELECT * FROM wp_fc_map_posts WHERE phpbb_id=

    failed to get topicYou have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1]
    SELECT * FROM wp_fc_map_posts WHERE phpbb_id=

  32. Ben Jackson Says:

    nope, didn’t do anything

  33. I forgot to merge the changes to the skip missing reply. I updated 1.06 again so download PhpbbToBbpress.php and wp-db-ex.php. Confirm the reconnecting in the logging area.

  34. Ben Jackson Says:

    well the reconnecting thing worked. New errors at bottom:

    Warning: mysql_ping(): 1748 is not a valid MySQL-Link resource in /home/benjacks/public_html/alphashows.com.au/wp-content/plugins/forumconverter/wp-db-ex.php on line 27

    Warning: mysql_ping(): 1748 is not a valid MySQL-Link resource in /home/benjacks/public_html/alphashows.com.au/wp-content/plugins/forumconverter/wp-db-ex.php on line 30

    Warning: mysql_close(): 1748 is not a valid MySQL-Link resource in /home/benjacks/public_html/alphashows.com.au/wp-content/plugins/forumconverter/wp-db-ex.php on line 32

    • Those are expected… they will be silenced. Was there any errors? Also, there is a long delay between the visual being updated just to let you know. I am looking into to fix that delay so it shows the status immediately.

  35. Ben Jackson Says:

    no but it just stopped again, once those errors come up it’s no longer doing anything.

  36. I updated the code again… can you give me the last 20 lines of the log window or any message at the bottom of the page right after all activity (spinning animation) ceases for that browser tab.

  37. Ben Jackson Says:

    no errors at bottom, here is the log window contents:

    converted forum Company Cast Members
    converted forum General
    converted forum Core Creative Team & Ensemble Members
    converted forum Ben Jackson
    relinking forum hierarchy
    fixing subcounts
    done processing forums
    converting posts…
    converting posts
    disconnecting
    reconnecting…
    reconnect success
    disconnecting
    reconnecting…
    reconnect success

  38. Thanks for this. I was able to get the converter to work, or at least it gave me a success message but I don’t know what to do next? I don’t see the forum in my bbpress. Any ideas? thanks.

    • Are you using BuddyPress? If your using BuddyPress, make sure you disable bbPress Forums in BuddyPress > Component Setup. Also, make sure the forums are marked public. By default, ForumConverter marks all forums Hidden. A forum is marked public, or rw, when it has the ACL flag ROLE_FORUM_STANDARD or ROLE_FORUM_FULL. To access your forum, put /forums to the end of your url WordPress blog or use go to the WordPress admin panel > Forums> click on Forum name, make sure the visibility is public and then click the view forum button. I am using BuddyPress 1.2.9 BTW.

      • touchstone Says:

        Thanks for your response. I’m not using BuddyPress. The /forums page is set to public. I went to the bbpress database and it’s empty even though the converter seemed to work and it did give me a success message. Is there something else I can try?

      • Can you check to see if the Topics section > All Topics, Replies section > All Replies, Forums section > All Forums in your admin panel contains entries? Also did you see if the visibility setting per forum is set to visible? If there are no entries, in all three sections then ForumConverter may have failed conversion. Did you run in administrator to view the forum because it can be hidden for people who are not logged on?

        All topics, forums, replies are placed on the wp_posts table and are marked as post_type of topic, forum, reply. They are not placed in a separate table like in the old versions of bbpress.

        Before the conversion make sure you set the permissions of your forums properly. It is possible that a forum does not have a default registered user permission thus the forum will be marked hidden. ForumConverter relies on defaults and not modified forum or super picky permissions.

        You may also try out the unreleased 1.08 in the branch folder also at http://plugins.trac.wordpress.org/browser/forumconverter.

  39. Vato Says:

    Got some strange problems, too. Seems like all posts are converted correctly and all forums + subforums are created but somehow since (Ithink it was) 1.0.3 I can’t see any more the attachment handling (green colored). Unfortunately the installation stops and the last messages I see is “mergin user…). I rechecked the wp-db and all posts are converted but installation stops as described above and there’s no spinning circle after about 15mins any more. One additional problem I have is: Somehow the posts are not shown in bbpress. I get this error although everything is set as published:

    “This forum contains 32 topics and 150 replies.

    Oh bother! No topics were found here!”

    As said I tried all versions from 1.0.3 – 1.0.6.

    Additionally: Could you do this for latest buddypress beta?

  40. Vato Says:

    Hi again! Just reinstalled a whole new XAMPP-Serve ron my local Win7 machine and voila:i got some steps further! Somehow this plugin doesn’t like my NGINX server cause all my tries to test it online didn’t work well. Now with local XAMPP I got this:

    adding inline attachment
    adding post/reply attachment
    adding post/reply attachment
    adding post/reply attachment
    relink top level posts to forum and subforums
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed
    marking topic closed

    • Where did it halt? The plugin needs a long time out period before it gets killed by PHP itself. You must set up the timeout in both your PHP and your MySQL or within this script or it will never complete.

  41. vato Says:

    Hi again! I maximized execution_time in php.ini and edited also script. But I get this:

    “cannot match userphpid to userwpid”

    • The plugin died as it said that it couldn’t lookup the phpBB user. Can you use phpmyadmin, or mysql.exe remote connection, and confirm the user exists in phpbb_users and in wp_fc_users? Several things could happen. The plugin did a bad job adding that user to the wp_fc_users and I need to fix that. Or the user was not contained in phpbb_users because they were deleted and you have a post linking to a deleted/missing user. Tell me what happened so I can patch it.

      • Change $this->fc_die(‘cannot match userphpid to userwpid’.$wpdb->last_error); to $this->fc_die(‘cannot match userphpid to userwpid’.$wpdb->last_error.’user: ‘.$post->phpbb_poster_id.’ post: ‘.$post->phpbb_id); to locate that user

  42. vato Says:

    Ok doing your patch now. Will report my results ASAP

  43. vato Says:

    Back again! I got this message here:

    “cannot match userphpid to userwpiduser: 582 post: 327”

    Now I rechecked if user_id 583 exists in phpbb3-userdb and found out that it is gone. Seems like the user deleted his account in phpbb! So I think you should set userid=1 for those cases. In my phpbb-db userid=1 is called “anonymous”. Seems like this is default for phpbb. Another option would be to map admin account to this cases.

    Btw: thx for all your efforts.

  44. Yeah… mapping it to anonymous is the solution. We have to make sure anonymous also is restricted to posting as well and resolve account conflicts if a wp user called anonymous.

  45. vato Says:

    Will check it now and report my results again ASAP

  46. vato Says:

    Here’s my next error:

    “problem locating forum id: “

    • Confirm the forum exists in phpbb. Modify the debug message so $this->fc_die(‘problem locating forum id: ‘.$wpdb->last_error); becomes $this->fc_die(‘problem locating forum id: ‘.$post->phpbb_forum_id); in both wp_fc_map_forums and phpbb_forums. The problem again can be that wp_fc_map_forums is missing a forum or the topic refers to a forum that is missing in the phpbb_forums because it was deleted or happens to be missing. The plugin stops because it cannot put that topic under a forum/subforum because it cannot find the forum/subforum.

      So can you confirm again with phpmyadmin that the number reported in the message exists in the table phpbb_forums with the same number in the forum_id column. Also check to see if that wp_fc_map_forums contains the phpbb_id of that number reported by the debug message.

      Did it progress even farther than before? Hopefully the connection didn’t timeout.

  47. vato Says:

    Ok! I am eagerly waiting for your solution!

    • Okay I updated the plugin. The plugin will create a hidden topic called “Orphaned Topics” when it encounters a topic with a missing forum id, the plugin should place that topic in the Orphaned Topics forum to be later be moved/deleted by a moderator or admin.

  48. vato Says:

    wow! great job, my friend!

    “Conversion completed!”

    Well done! Had a quick look on it and it seems like everything is ok! Will test-drive bbPress now and see if something is missing but I can confirm your plugin as fully working for the moment!

  49. vato Says:

    How about avatars? What exactly do I have to put in “Source server avatar path”

    • For that you make sure you put the folder location of where phpbb uploads the avatars to. In my case I directed it to C:\www\bbs\images\avatars\upload. You may find it in phpbbfolder/images/avatars/upload. It will be different on your machine.

      • Avatars support only works if you have BuddyPress installed since WordPress doesn’t have upload avatar support.

      • vato Says:

        Ok got it! Thank you! I am testing this in next days together with my forum moderators. I’ll post all issues which we may find here.

  50. Vato Says:

    Seems like there’s a small problem with permissions. Although I have set all forums now to “published” still guests / anonymous users are not able to view the forums. They receive the following message:

    “Oh bother! No forums were found here!”

    That’s not only related to guest users. Also registered users and the WP-admin-account receives “Oh bother! No forums were found here!” message when viewing specific forums. In General 99% of my phpbb3 have had read-access for everyone. So this is somewhat of strange now to me. I am not sure what went wrong on my site but I am also using Buddypress (with disabled forums) in addition with bbpress. Any ideas are welcome….

    • Vato Says:

      have to correct myself. All forums were “hidden” status. I set all to publish after converting. I am sure about this. Seems like some bug in bbpress not in your converter..Sorry!

  51. Vato Says:

    Hi Orson,

    I just commented out 2 lines in PhpppToBBpress.php to get conversion started with bbpress 2.0rc3.

    // if ($dbver != ‘110’) //2.0-beta-3b
    // $this->fc_die(‘conversion is not supported’);

    Dunno if conversion will do it’s job correctly but could be useful for those reading your blog.

    • Vato Says:

      Another problem I have is BBCode conversion since beginning to use your converter. It won’t work although I have BBCode-Lite installed and enabled the option “use BBcode instead of HTML markup”.

      For e.g. [b]test-text[/b] remains like it is. I would have to change it to test-text to get it to display in bold. Same for all other BBcodes from phpbb.

      Some more examples:
      [b][size=150:1taejwku][color=#8040BF]Reported Bugs[/color][/size][/b]
      [size=150:1taejwku][url=http://www.multiupload.com]Multiupload[/url][/size]

      Seems like there’s a problem. I rechecked my Db and it is set to UTF on both databases. As m

    • Vato Says:

      Another problem I have is BBCode conversion since beginning to use your converter. It won’t work although I have BBCode-Lite installed and enabled the option “use BBcode instead of HTML markup”.

      For e.g. [b]test-text[/b] remains like it is. I would have to change it to test-text to get it to display in bold. Same for all other BBcodes from phpbb.

      Some more examples:
      [b][size=150:1taejwku][color=#8040BF]Reported Bugs[/color][/size][/b]
      [size=150:1taejwku][url=http://www.multiupload.com]Multiupload[/url][/size]

      Seems like there’s a problem. I rechecked my Db and it is set to UTF on both databases. As you may see I have problems with dots and other stuff after conversion.

      • You may need to write your own code… because the converter just does a 1-to-1 cleanup stripping away the :1taejwku. If you want it separate it needs to be [b]test[/b]-[b]text[/b] to handle special case with hyphens. The [size=150:1taejwku] is incorrect, I need to fix it so it generates [size=150].

      • BBCode-Lite needs its hooks updated because they are either non existent or have change their name. It is not compatible with bbPress 2.0 unless you change the source code with the new hook names.

  52. Tom Says:

    I know I must be a serious dimwit here-
    When starting conversion, in yellow it says “Starting conversion”. In red it says “conversion failed”. At the bottom it says “conversion is not supported”. This does not give me enough info to know what I did wrong.
    First off, are my URL’s formatted properly?
    Source server hostname: http://mysql.xxxxxxx.org
    Database name: xxxxx_org
    Source server upload path : http://xxxxxxxxx.org/myforum/files
    Source server avatar path : http://xxxxxxxx.org/myforum/images/avatars/upload

    Thanks for the effort!

  53. chrchcol Says:

    I get conversion is not supported when I try to run the forum conversion plugin. Any ideas?

    • The message is triggered because (1) the database version is not in bbPress 2.0 beta 3 or above (2) you did not activate bbPress. You can bypass the check by editing PhpbbToBbpress.php and adding // in the beginning of lines 34 and 35.

      • chrchcol Says:

        Is there a way to bypass the mysql ping if they make the mysql host unpingable?

        Warning: mysql_ping() expects parameter 1 to be resource, boolean given in /home/hunting/www/www/wp-content/plugins/forumconverter/wp-db-ex.php on line 38
        reconnect failed

      • Edit wp-db-ex.php and
        change line 30 to
        //while (@mysql_ping($this->dbh) === FALSE && $tries dbh) === TRUE && $disconnected == true)
        // $this->fc_echo(‘reconnect success
        ‘);

        line 39 is triggering it because the other pings are silenced and I just saw a bug.

  54. chrchcol Says:

    That errors also. IF you change line 30 to that it errors down in another line. Can the ping be bypassed entirely?

  55. chrchcol Says:

    I finally got it to work by commenting out the check connection. It goes line by line through the conversion and then says conversion completed. However in wordpress there are no users added, there are no forums added, there are no topics added. Its almost like the conversion ran with no problem but did not complete. Is this because I commented out the check connection? Is something else wrong?

    • Check that your forums are marked public under admin. Also check the database directly with phpmyadmin if it actually did the conversion by inspecting the wp_posts and wp_users tables.

  56. chrchcol Says:

    The database has no import informathion. The old forum is not set to private. Any other ideas?

  57. You can try out the 1.08 experimental branch at http://plugins.trac.wordpress.org/browser/forumconverter in the branches folder. Did you meant to say that the WordPress wp_users database has no entries with phpbb in the pass field and there were no wp_posts of type forum/reply?

  58. Can we get a version that supports conversion to bbpress 2.0-rc-4 please?

    • I will look into it. Any changes to 2.0-rc-4 will be applied in the final version of ForumConverter 1.08. You could try to disable version checking in the source code if your in a hurry to test if it works.

  59. Bobek Says:

    Waiting for upgrade
    Latest 2.0 RC 4 😦

    Sombody know where I can download previous version ?

    • Bobek Says:

      I have tried to convert with disabled version checking and get only errors:
      “Warning: scandir(/forum/images/upload/) [function.scandir]: failed to open dir: No such file or directory in /rkf/wp-content/plugins/forumconverter/PhpbbToBbpress.php on line 1767

      Warning: scandir() [function.scandir]: (errno 2): No such file or directory in /rkf/wp-content/plugins/forumconverter/PhpbbToBbpress.php on line 1767

      Warning: array_shift() [function.array-shift]: The argument should be an array in /rkf/wp-content/plugins/forumconverter/PhpbbToBbpress.php on line 1768

      Warning: array_shift() [function.array-shift]: The argument should be an array in /rkf/wp-content/plugins/forumconverter/PhpbbToBbpress.php on line 1769

      Warning: Invalid argument supplied for foreach() in /rkf/wp-content/plugins/forumconverter/PhpbbToBbpress.php on line 1770

      Have to wiat for updated version of plugin

      • The plugin is updated to 1.08 just now just to let you know.

      • Bobek Says:

        Thank You for info 🙂
        Still I get problem with converting forum.
        This is error I get:

        any ideas ?

      • Sorry if I haven’t replied soon enough, the source of the error is related to avatar support. You can try to comment out the code and see if it works. It may be related to folder permissions. You should check the permissions of the folder. It is most likely not a ForumConverter problem.

  60. Vato Says:

    Hi again Orson 🙂
    I have problems with phpBB3 file attachments (both: inline and post attachments). Either they aren’t even attached or wrongly linked. Look at this:

    Download‌·
    x1.zip
    .‌·(Caution:‌·This‌·file‌·may‌·not‌·be‌·virus‌·scanned.)

    Should be x1.zip but points to a JPG????

  61. Vato Says:

    I have been able to define the problem: all attachments are linked to the same file! In my case http://localhost/wp-content/uploads/bbpress/22555/test2.jpg

  62. Vato Says:

    Orson here is my modified BBCode-aprt as promised earlier. It does this:

    – Corrects things like [b:asdghfsad] [url=http://www.google.de:sdfgfdsfsdf] [color=#ffffff:asfgsdf] etc…
    – removes all smilies to have a clean new converted forum
    – removes all sizes to have a clean new converted forum

    Maybe you can finetune it. But this one I am posting works fine for me now.

    http://pastebin.com/PJhT8cv1

  63. Vato Says:

    Hi orson any timeframe of seeing updates? Both bbPress and BuddyPress are final now. I am just asking cause I will migrate from phpbb3 forums within a week. I have no problems at all with your plugin 1.10 at all but maybe you genius have some additional things in ya mind to add (like those images talked about earlier…)

    • I would like to merge your changes, but it is not in a unified .diff format, using gnu diff. If your merges get accepted how do you want to be credited? Thanks for passing the word about the status of both bbPress and BuddyPress. I won’t be releasing any major changes to the code I will likely bring the code up to date on the weekend.

  64. Vato Says:

    yes it’s not unified .diff but you should be easily merging it. regarding credits I don’t care about. I am just happy about your work and I will convert my working phpbb3 forum at http://www.neopeek.com to bbPress with your great plugin

  65. mojave3ed Says:

    Hi, when running the converter, everything seems to work, except the topic titles – these are blank. And thus, nothing works! Looking the database, it seems that data didn’t get carried over properly from phpbb3.

    Any ideas?

  66. mojave3ed Says:

    oh, and the link between users and posts also seems broken… 😦

  67. Roslyn Says:

    I’m having problems – I keep getting “Conversion failed”. Any ideas?
    It is on the same host so using localhost
    DB details are correct.
    Versions of WP and phpBB are correct.
    Path to upload files: documentroot/l/forum/files/ – forum is the directory I have the :”forum” in.
    I haven’t bothered with the avatar path.

  68. Roslyn Says:

    Okay, I upgraded forum converter today and have run it again. It is still doing something – page hasn’t changed. It just says it is waiting for my website and the page still says “Connecting”. Any idea how long this can take?

    It must be doing something because the rest of the website is not loading either. That isn’t a problem because it is a subdomain sitting on a different server with just a mirror of the main website all redirecting back to the main website(normally) and the forum.

  69. Roslyn Says:

    conversion complete! Thanks – I still need to set up the rest.

  70. Vato Says:

    Hi Orson!

    V1.11 works perfect for me here! No issues!
    God bless you!

  71. mojave3ed Says:

    same problem as before, everything transfers except the topic titles. All looks fine in phpbb3, but after conversion, gone …. 😦

  72. Adam Says:

    Hello,

    I just converted my phpBB database with your ForumConverter. Everything worked fine, but I have a few questions.

    1) I’m not sure what ForumConverter-Auth, ForumConverter-Password and ForumConverter-Signatures does. (If I can remove them)
    2) After conversion whan i look into the “wp_users” table, all users (exept admin – created by WordPress) have password like phpbb$H$9gcR7JQ/wXigbjPmcyGbqZKilj4jSc0 . Is that all right? Or shoud I remove the “phpbb” part?

    Thanks for this great plugin, I’m looking forward to your answers.

    Adam

    • To answer question number one… The -Auth module is used for post conversion support. Basically it takes an existing phpbb password and allows a user to login with their phpbb password. -Password is used for support for forums that have a phpbb password associated with them. The tool allows you to use an existing phpbb forum password and also allows you to remove the phpbb password support. The signature support is used for support for phpbb signatures. This one is optional. Basically you may want to allow backwards compatibility for forum signatures.

      To answer the second question. The phpbb prefix is used to detect between a phpbb password and a regular wordpress password. Do not remove that but also do not disable the auth module.

  73. Patrick Says:

    Hi,

    first, thx for the plugin. on my installation the conversion from phpbb does not work. I start the conversion and the folloging informations i can read on screen:

    Please wait while conversion in progress…
    starting conversion…
    cleaning up…
    converting users…
    converting users

    I can wait, and wait and wait, but nothing changes.

    What do i wrong?
    Hope you can help me.

    I use wp 3.2.1 and phpbb 3.0.9.

  74. marpo22 Says:

    Help pls 😦

  75. Quick question – I’ve gotten to the point where the converter is running and the log reads:

    “converting posts…
    converting posts
    disconnecting
    reconnecting…
    reconnect success”

    but it seems to hang there. I uncommented show_errors() to see if there was an issue to no effect. If I’m trying to convert a particularly large db (~55k posts) any idea on how long I should give it before officially declaring that there must be something going wrong?

    • Maybe you need to increase the script timeout length. PHP has a limit how long a script can execute.

      • Sorry should have mentioned I did that – upped that to about 5 hours, but it’s still stalling in the same place.

        It looks like when a query returns more than 11995 rows the object just empties without throwing an error that I can find. Know of any way around this?

      • You may need to change the query limit for the mysql account. You can read more about it here http://dev.mysql.com/doc/refman/5.0/en/user-resources.html
        You may need to edit the source code to process each set using the LIMIT clause for the SELECT SQL statement. What I mean is that you would partition the query so like 0-5000, 5001-10000, 10001-15000
        What part of the conversion does it pause? Was the web browser tab spinning like it was still busy? If you don’t know, put some debug counter result to indicate the index of what post it is currently processing to indicate if it is working.

  76. Vato Says:

    Hi Orson, it’s me again 🙂
    Hope you are fine. I got one question: as you explained earlier the Auth-Module is used for supporting the phpbb user passwords. Basically I am trying to use as few plugins as possible. And while WP3.3 just came out I was asking myself if there would be a possibility to add a user-password-converter to the converter itself so that we can get rid off the auth module (plugin). Dunno if that’s possible due to sum md5 / salt / hash related stuff but I just thought asking you would be the best….

    For Wp3.3 I had to take out the check for dbversion in phptobbpress.php to get the conversion started


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s